technik:tinc_olsr:clientwlan

Client WLAN

Neben den Freifunk-Knoten gibt es im Freifunk-Netzwerk auch noch die normalen Nutzern, die mit Notebook, Smartphone etc. daher kommen.

Diese Teilnehmer sollen nicht im Ad-Hoc Modus am WLAN teilnemen, sondern ganz regulär im Infrastructure Modus. Dafür bietet jeder Freifunk-Knoten ein WLAN im Master-Mode an.

Die ESSID dieses WLANs muss eindeutig sein, insofern dieser Freifunk-Knoten aus einem eigenen Adressbereich per DHCP IP-Adressen verteilt. Nur dieser Adressbereich wird korrekt geroutet.

Die ESSID könnte für unseren Beispielknoten so aussehen: freifunk-stuttgart.net-SExample01

Unser Beispielknoten die IP-Adresse 172.21.99.1 und das Netzwerk 172.21.99.0/28 zur Verfügung. Es können also die Adressen 172.21.99.2 bis 172.21.99.14 an Clients vergeben werden.

/etc/config/wireless
...
config wifi-iface                            
        option device 'radio0'               
        option mode 'ap'                     
        option encryption 'none'             
        option ssid 'freifunk-stuttgart.net-SExample01'
        option network 'freifunk_ap'
...

Wichtig hierbei ist, dass die Beziehungen zu „device“ und „network“ stimmen.

/etc/config/network
...
config interface 'freifunk_ap'        
        option proto 'static'            
        option ipaddr '172.21.99.1'   
        option netmask '255.255.255.240' 
...
/etc/config/dhcp
...
config dhcp                                          
        option interface 'freifunk_ap'               
        option start '2'                             
        option leasetime '24h' #Kann auch kürzer gewählt werden                      
        option limit '14' #Anzahl der Adressen, nicht das Ende des Bereichs                            
...
  • technik/tinc_olsr/clientwlan.txt
  • Zuletzt geändert: vor 18 Monaten
  • (Externe Bearbeitung)